尺取//POJ - 3061

尺取//POJ - 3061


题目

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3
题意
求最短连续多少个数的和为题目要求的数
链接:https://vjudge.net/contest/347799#problem/A

思路

尺取模板题。

代码

#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <stack>
#include <queue>
#include <cstring>
using namespace std;

int a[100000+1000]={0};
int main()
{
    int T;
    cin>>T;
    while(T--){
        int n,s;
        cin>>n>>s;
        for(int i=0;i<n;i++){
            cin>>a[i];
        }
        int l=0,r=0,sum=0,ans=0;
        while(1){
            while(sum<s&&r<n){
                sum+=a[r];
                r++;
            }
            if(sum>=s){
                if(r-l<ans||ans==0)
                    ans=r-l;
            }
            if(l==n) break;
            sum-=a[l++];
        }
        cout<<ans<<endl;
    }
    return 0;
}

注意

发布了24 篇原创文章 · 获赞 9 · 访问量 544

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/103963376