【poj 3061】尺取法

部分内容转载自

http://blog.csdn.net/consciousman/article/details/52348439

介绍

尺取法通常是对数组保存一对下标,即所选取的区间的左右端点,然后根据实际情况不断地推进区间左右端点以得出答案。之所以需要掌握这个技巧,是因为尺取法比直接暴力枚举区间效率高很多,尤其是数据量大的
时候,所以尺取法是一种高效的枚举区间的方法,一般用于求取有一定限制的区间个数或最短的区间等等
尺取法通常适用于选取区间有一定规律,或者说所选取的区间有一定的变化趋势的情况,通俗地说,在对所选取区间进行判断之后,我们可以明确如何进一步有方向地推进区间端点以求解满足条件的区间,如果已经判断了目前所选取的区间,但却无法确定所要求解的区间如何进一步
得到根据其端点得到,那么尺取法便是不可行的。首先,明确题目所需要求解的量之后,区间左右端点一般从最整个数组的起点开始,之后判断区间是否符合条件在根据实际情况变化区间的端点求解答案。

首先先上一道例题

Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

大意

给出N个数字,每个数字不大于10000,给出一个S,在N个数字中挑选出连续的a的数字,使这a个数字的和大于或等于S。请问这个a最小是几

思路:

一道尺取法的例题,确实很好,尺取法O(n)解决一些极其好的问题
如果一个区间其和大于等于S了,那么不需要在向后推进右端点了,因为其和也肯定大于等于S但长度更长,所以,当区间和小于S时右端点向右移动,和大于等于S时,左端点向右移动以进一步找到最短的区间,如果右端点移动到区间末尾其和还不大于等于S,
结束区间的枚举。
这个题目区间和明显是有趋势的:单调变化,所以根据题目要求很容易求解,但是在使用之间需要对区间前缀和进行预处理计算

代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
int a[100050],t,n,s;
int main()
{
cin>>t;
while (t!=0)
{
    t--;
    cin>>n>>s;
    for(int i=1;i<=n;i++) cin>>a[i];
    int sum=0,q=1,e=1,ans=n+1;
    for(;;)
    {
        while(e<=n&&sum<s)
        {
            sum+=a[e];
            e++;
        }
        if(sum<s)
            break;
        ans=min(ans,e-q);
        sum-=a[q];
        q++;
    }
    if(ans==n+1)
        cout<<0<<endl;
    else 
        cout<<ans<<endl;
}
return 0;
}
发布了75 篇原创文章 · 获赞 80 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_36693514/article/details/78320753
今日推荐