【尺取法】POJ - 3061 Subsequence

Subsequence  POJ - 3061

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3
#include <iostream>
#include <cstdio>
using namespace std;
int n,s,a[100005];

void solve()
{
    int res = n + 1;
    int left = 1, right = 1, sum = 0;
    while(1)     
    {
        while(right <= n && sum < s)  //限制条件,不超过边界且sum<s
        {
            sum += a[right++];
        }
        if(sum < s) break;   //要是全部走完,sum都小的话,就跳出循环
        res = min(right - left, res);  //不断更新答案
        sum -= a[left++];    //减掉后面的继续走
    }
    if(res > n) printf("0\n");  //要是全部加起来都比要求的s小,就是0
    else printf("%d\n", res);
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &s);
        for(int i = 1; i <= n; i ++)
        {
            scanf("%d", &a[i]);
        }
        solve();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81303439