//经典尺取法//poj3061//Subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

解题思路:
和上一道题思路基本一致,只不过是序列中没有负数,更简单一些。
要注意如何推进端点,因为区间和只要大于等于s就符合要求,所以区间和小于等于s的时候都推进右端点,大于s的时候推进左端点,当left==right的时候推进右端点。

#include<stdio.h>

int n,s,num[100005],pre[100005];

void solve()
{
    int flag=1,left=0,right=1,min=0x3f3f3f3f,ans,sum;
    while(right<=n)
    {
        sum=pre[right]-pre[left];
        if(sum>=s&&right-left<min)
        {
            flag=0;
            min=right-left;
        }
        if(sum>s)
            left++;
        else
            right++;
        if(left==right)
            right++;
    }
    if(flag==0)
        printf("%d\n",min);
    else
        printf("0\n");
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        pre[0]=0;
        scanf("%d%d",&n,&s);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            pre[i]=pre[i-1]+num[i];
        }
        solve();
    }
}

猜你喜欢

转载自blog.csdn.net/lydia_ke/article/details/79419882