POJ--3061--尺取法

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

思路一:二分搜索;时间复杂度O(n*logn);

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define min(a,b) a<b?a:b
using namespace std;
int n,S;
int a[100000+10],sum[100000+10];
void solve(){
	for(int i=0;i<n;i++){
		sum[i+1]=sum[i]+a[i];//计算sum 
	}
	if(sum[n]<S){ 
		printf("0\n");
		return; 
	}
	
	int ans=n;
	for(int i=0;sum[i]+S<=sum[n];i++){
		int t=lower_bound(sum+i,sum+n,sum[i]+S)-sum;
		ans=min(ans,t-i);
	}
	printf("%d\n",ans);
	return ; 
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		memset(a,0,sizeof(a));
		memset(sum,0,sizeof(sum));
		scanf("%d%d",&n,&S);
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		solve();
	}
	return 0;
} 

思路二:尺取法;时间复杂度O(n);

#include<cstdio>
#include<algorithm>
#define min(a,b) a>b?b:a
int n,S;
int a[100000+10];
void solve(){
	int ans=n+1;
	int s=0,t=0,sum=0;//尺取法记录下标
	for(;;){
		while(t<n&&sum<S){
			sum+=a[t++];
		}
		if(sum<S)
			break;
		ans=min(ans,t-s);
		sum-=a[s++];
	} 
	if(ans==n+1)
		printf("0\n");//解不存在
	else
		printf("%d\n",ans); 
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){ 
		scanf("%d%d",&n,&S);
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		solve(); 
	}
	return 0;
} 
发布了150 篇原创文章 · 获赞 73 · 访问量 6602

猜你喜欢

转载自blog.csdn.net/queque_heiya/article/details/104142289
今日推荐