POJ - 3061 Subsequence (尺取法

版权声明:欢迎加好友讨论~ QQ1336347798 https://blog.csdn.net/henu_xujiu/article/details/81774493

题目链接 

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3 

以前学过的一个方法,代码解释在自己电脑里,先把ac代码放上回头再更新笔记版代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;
int a[100005];
int n,S;
void slove()
{
	int res=n+1;
	int s=0,sum=0,z=0;
	for(;;)
	{
		while(z<n&&sum<S)
		{
			sum+=a[z++];
		}
		if(sum<S)break;
		res=min(res,z-s);
		sum-=a[s++];
	}
	if(res>n)
		res=0;
	cout<<res<<endl;
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n>>S;
		for(int i=0;i<n;i++)
		{
			cin>>a[i];
		}
		slove();
	}
}

猜你喜欢

转载自blog.csdn.net/henu_xujiu/article/details/81774493
今日推荐