Poj 3061 Subsequence 尺取法

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

 求一个连续序列大于等于s的最小长度....

尺取法.....

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=100005;
const int INF=0x3f3f3f3f;
int t;
int n,s;
int a[maxn];
void Ruler ()
{
    int st=0,en=0,temp=0,ans=INF;
    while (1)
    {
        while (temp<s&&en<n)
        {
            temp+=a[en++];
        }
        if(temp<s)
        {
            break;
        }
        ans=min(ans,en-st);
        temp-=a[st++];
    }
    if(ans==INF)
    {
        printf("0\n");
    }
    else
        printf("%d\n",ans);
}
int main()
{
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&n,&s);
        for (int i=0;i<n;i++)
            scanf("%d",&a[i]);
        Ruler();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/83038025