poj-3061-Subsequence(尺取法)

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.Description

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
ll m,S;
ll a[100010];
void solve(){
	ll res = m+1,sum = 0,t = 0,s = 0;  // t为尺取区间的尾,s为尺取区间的开始,
	for(;;){
		while(t < m&&sum < S){  //当t小于数组长度并且区间和小于S时,一直向后取数
			sum+=a[t++];    
		}
		if(sum < S) break;    //区间和小于S,跳出循环
		res = min(res,t-s);    
		sum-=a[s++];    //区间和大于S时,从区间开始的地方向后移,缩短区间
	}
	if(res > m){
		res = 0;
	}
	printf("%lld\n",res);
}

int main(){
	int n;
	scanf("%d",&n);
	while(n--){
		scanf("%lld%lld",&m,&S);
		for(int i = 0;i < m;i ++){
			scanf("%lld",&a[i]);
		}
		solve();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qlp_123/article/details/81236720
今日推荐