poj-3061-Subsequence & 尺取法

1.尺取法定义

尺取法通常是指对数组保存一对下标(起点、终点),然后根据实际情况交替推进两个端点直到得出答案的方法。

2.poj3061

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive(连续的) elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval(间隔), from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

给定长度为N的正整数数列以及整数S,求出总和不小于S的连续子序列的长度的最小值。
因为都是正整数,所以可以这样:
下为代码。自行体会,不要复制粘贴。等我什么时候能够把思路说得比较清楚了再填这个坑
说白了,如果sum小于S,就把t增加1,否则s增加1。当然sum也是要更新的。

#include<cstdio>
#include<algorithm>
#define maxn 100005
using namespace std;
int t,n,s,a[maxn];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&s);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        int ans=maxn,cnt=0;
        for(int l=1,r=0;r<=n;)
        {
            if(cnt<s) cnt+=a[++r];
            else ans=min(r-l+1,ans),cnt-=a[l++];
        }
        printf("%d\n",ans==maxn?0:ans);
    }
}

写了一半发现这似乎写不了多少..到时候再弄点题上来emmm。

猜你喜欢

转载自blog.csdn.net/dogeding/article/details/79315350