抽屉问题 吃糖果

Problem Description
HOHO,终于从Speakless手上赢走了所有的糖果,是Gardon吃糖果时有个特殊的癖好,就是不喜欢将一样的糖果放在一起吃,喜欢先吃一种,下一次吃另一种,这样;可是Gardon不知道是否存在一种吃糖果的顺序使得他能把所有糖果都吃完?请你写个程序帮忙计算一下。
 
Input
第一行有一个整数T,接下来T组数据,每组数据占2行,第一行是一个整数N(0<N<=1000000),第二行是N个数,表示N种糖果的数目Mi(0<Mi<=1000000)。
 
Output
对于每组数据,输出一行,包含一个"Yes"或者"No"。
 
Sample Input
2 3 4 1 1 5 5 4 3 2 1
 
Sample Output
No Yes
 
 
1.贪心+ 堆
2.插板法 当maxx-1<=sum 时 一定行 否则不行
//
#include<bits/stdc++.h>
using namespace std;
priority_queue <int > Q;
int T,m,n;

int main()
{
    cin>>T;
    int x;
    while(T--)
    {
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>x;
            Q.push(x);
        }
        int fla=0;
        while(Q.size())
        {
            int s=Q.top();
            Q.pop();
            s--;
            while(Q.size()&&s)
            {
                int k=Q.top();
                Q.pop();
                if(s<k)
                {
                    Q.push(k-s);
                    s=0; 
                } 
                else
                {
                    s-=k;
                }
            }
        if(s!=0)
        {
            cout<<"No"<<endl;
            fla=1;
        }
    }
        if(fla==0) cout<<"Yes"<<endl;
    }
    
    
}
 

猜你喜欢

转载自www.cnblogs.com/OIEREDSION/p/11308441.html