HDU--1205--吃糖果

HOHO,终于从Speakless手上赢走了所有的糖果,是Gardon吃糖果时有个特殊的癖好,就是不喜欢将一样的糖果放在一起吃,喜欢先吃一种,下一次吃另一种,这样;可是Gardon不知道是否存在一种吃糖果的顺序使得他能把所有糖果都吃完?请你写个程序帮忙计算一下。 

Input

第一行有一个整数T,接下来T组数据,每组数据占2行,第一行是一个整数N(0<N<=1000000),第二行是N个数,表示N种糖果的数目Mi(0<Mi<=1000000)。 

Output

对于每组数据,输出一行,包含一个"Yes"或者"No"。 

Sample Input

2
3
4 1 1
5
5 4 3 2 1

Sample Output

No
Yes


        
  
Please use function scanf

Hint

Hint
        
 参考链接:https://blog.csdn.net/wyf12138/article/details/51582012
#include <iostream>
#include <cmath>
#include <algorithm>

using namespace std;

const int N = 1000000;
int s[N+1];

int main(void)

{
	int T;
	cin >> T;
	while(T--){
		int n,max=0;
		cin >> n;
		for(int j=0;j<n;j++){
			cin >> s[j];
			if(s[j] > max)
			    max = s[j];
		}
		int sum=0;
		int j;
		for(j=0;j<n;j++){
			if(s[j] != max)
			    sum+=s[j];
			if(sum >= max-1)
			    break;
		}
		if(j==n)
		    printf("No\n");
		else 
		    printf("Yes\n");
		
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiaorui98/article/details/82620210