hdu 1205 吃糖果(抽屉原理)

Problem Description

HOHO,终于从Speakless手上赢走了所有的糖果,是Gardon吃糖果时有个特殊的癖好,就是不喜欢将一样的糖果放在一起吃,喜欢先吃一种,下一次吃另一种,这样;可是Gardon不知道是否存在一种吃糖果的顺序使得他能把所有糖果都吃完?请你写个程序帮忙计算一下。

Input

第一行有一个整数T,接下来T组数据,每组数据占2行,第一行是一个整数N(0<N<=1000000),第二行是N个数,表示N种糖果的数目Mi(0<Mi<=1000000)。

Output

对于每组数据,输出一行,包含一个"Yes"或者"No"。

Sample Input

2 3 4 1 1 5 5 4 3 2 1

Sample Output

No Yes

#include <cstdio>
#include <cstring>
#include<iostream>
#include <algorithm>
using namespace std;
long long t,n,a[1000000+66],sum=0;
int main()
{
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            sum+=a[i];
        }
        sort(a+1,a+n+1);//排序找到最大的那个数;
        sum-=a[n];
        //最多有一个为空,就是把最多的那个数量为n的糖果当成n个抽屉,然后每个抽屉放糖果,最多只能有一个抽屉为空,也就是sum>=a[n]-1;
        if(sum+1>=a[n])
            printf("Yes\n");
        else{
            printf("No\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/81667744