nyoj 546-Divideing Jewels(多重背包优化)

题目描述:

 

Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

 

输入描述:

Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000. The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line. 

输出描述:

For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case. 

样例输入:

复制

1 0 1 2 0 0 0 0 2 0
1 0 0 0 1 1 0 0 0 0
0 0 0 0 0 0 0 0 0 0

样例输出:

#1:Can't be divided.

#2:Can be divided.


提示:

没有提示哦

来源:

第五届河南省程序设计大赛

代码提交

  • 题意是每组测试数据给出十个数,第几个数表示价值为几的物品有几个,问能否将这些物品分成两等份

思路就是若能分成两等份,则每份的价值就是总和/2,判断这个值的容量能否正好装满该值的价值。若

能即可分,反之则不行。转化成背包问题,可以用二进制拆分来优化。

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
const int N = 1e5 + 10;
int a[20], b[N];
int d[N];
int main(){	
	//freopen("D:/input.txt", "r", stdin);
	int cnt = 0;
	while (true)
	{
		memset(d, 0, sizeof d);
		cnt++;
		int sum = 0;
		for (int i = 1; i <= 10; i++)
			cin >> a[i], sum += a[i] * i;
		if (sum == 0)
		{
			cout << endl;
			return 0;
		}
		if (sum % 2 != 0)  // sum为奇数一定不能分
			printf("#%d:Can't be divided.\n", cnt);
		else
		{
			int x = 0;
			int m = sum / 2; //m为容量
			for (int i = 1; i <= 10; i++)   //二进制拆分物品
			{
				for (int j = 1; j <= a[i]; j <<= 1) 
				{
					b[x++] = i * j;
					a[i] -= j;
				}
				if (a[i] > 0)
					b[x++] = i * a[i] ;
			}
			for (int i = 0; i < x; i++)   //01背包
				for (int j = m; j >= b[i]; j--)
					d[j] = max(d[j], d[j - b[i]] + b[i]);
			if (d[m] == m)
				printf("#%d:Can be divided.\n", cnt);
			else
				printf("#%d:Can't be divided.\n", cnt);
		}
		cout << endl;
	}
	return 0;
}

 

 


 


 

 


  •  

 

猜你喜欢

转载自blog.csdn.net/weixin_43731933/article/details/89764427