nyoj 546 难度4 第五届河南省程序设计大赛

多重背包优化----Divideing Jewels

时间限制:1000 ms  |  内存限制:65535 KB

难度:4

描述

Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

输入

Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000. 
The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line. 

输出

For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case. 

样例输入

1 0 1 2 0 0 0 0 2 0

1 0 0 0 1 1 0 0 0 0

0 0 0 0 0 0 0 0 0 0

样例输出

#1:Can't be divided.

#2:Can be divided.

来源

第五届河南省程序设计大赛

上传者

rihkddd

题意

给你价值从1到10,每种珠宝的个数,问Rose和Mary两姐妹能不能平均分,都得到相同价值的珠宝。

输入

珠宝总个数小于10000. 
输入 "0 0 0 0 0 0 0 0 0 0";结束

输出

输出 "#k:", k为测试数据的组数 如果能分输出"Can be divided." 不能分输出 "Can't be divided.".

思路:对于每种珠宝要是偶数个只保留2个用来凑和,多余的直接平分,要是奇数个只保留1个凑和,其余的偶数个可以直接平分。记录保留的价值之和是奇则一定不可能平分,是偶数还要用01背包的算法计算一下如果dp[sum/2]==sum;则一定能平分,预处理完就类似于两兄弟分邮票这道题了。

//根据题意巧妙化为01背包来做
#include<stdio.h>
#include<string.h>
int dp[100],a[15];
int main()
{
	int kase=1;
	while(1)
	{
		int x,p=1,flag=0,m,sum=0,t=0;
		memset(dp,0,sizeof dp);
		memset(a,0,sizeof a);
		for(int i=1;i<=10;i++)
		{
			scanf("%d",&x);
			if(x==0) t++;
			else{
				if(x%2==0){
					a[p++]=i;a[p++]=i;
					sum+=i*2;
				}
				else{
					a[p++]=i;sum+=i;
				}
			}
		}
		if(t==10)return 0;
		if(sum%2==0){
		    m=sum/2;
			flag=1;
			for(int i=1;i<p;i++){
				for(int j=m;j>=a[i];j--)
				    if(dp[j]<dp[j-a[i]]+a[i])
				    dp[j]=dp[j-a[i]]+a[i];
			}
		}
		if(flag&&dp[m]==m) printf("#%d:Can be divided.\n",kase++);
		else printf("#%d:Can't be divided.\n",kase++);
	}
}
 

一般的多重背包优化

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int m;
int a[10005],dp[100007];
void zero(int cost,int value){
	for(int i=m;i>=cost;i--)
		dp[i]=max(dp[i],dp[i-cost]+value);
}
void complete(int cost,int value){
	for(int i=cost;i<=m;i++)
		dp[i]=max(dp[i],dp[i-cost]+value);
}
void multi(int cost,int value,int num){
	if(num*cost>=m)
	{
		complete(cost,value);
		return ;
	}
	int k=1;
	while(k<num)
	{//不能选无线多个就按01背包来做
		zero(k*cost,k*value);
		num-=k;
		k*=2;
	}
	zero(num*cost,num*value);
}
int main()
{
	int kase=1;
	while(1){
		int sum=0;
		int flag=0;
		memset(dp,0,sizeof dp);
		for(int i=1;i<=10;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i]*i;
		}
		if(sum==0)return 0;
		if(sum%2==0){
			m=sum/2;
			flag=1; 
			for(int i=1;i<=10;i++)
			{
				multi(i,i,a[i]);
			}
		} 
		if(flag&&dp[m]==m){
			printf("#%d:Can be divided.\n",kase++);
		}
		else{
			printf("#%d:Can't be divided.\n",kase++);
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_36914923/article/details/80377594
今日推荐