PAT 1002. A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

提交了很多次都是部分通过,没有考虑到double的输出位数,添加下面一行控制输出位数

cout<<fixed<<setprecision(1)<<p[i];

#include <iostream>
#include<iomanip>
using namespace std;

int main()
{
    int line1Length = 0;
    int line2Length = 0;
    int index = 0;
    double value = 0.0;
    double p[1111];
    int count = 0;

    for(int i = 0;i < 1111;i++)
    {
        p[i] = 0.0;
    }
    cin>>line1Length;
    for(int i = 0;i < line1Length;i++)
    {
        cin>>index;
        cin>>value;
        p[index] += value;
    }

    cin>>line2Length;
    for(int i = 0;i < line2Length;i++)
    {
        cin>>index;
        cin>>value;
        p[index] += value;
    }

    for(int i = 0;i < 1111;i++)
    {
        if(p[i] != 0)
        {
            count++;
        }
    }
    cout<<count;

    for(int i = 1110 ;i > -1 ;i--)
    {
        if(p[i] != 0)
        {
            cout<<" ";
            cout<<i<<" ";
            cout<<fixed<<setprecision(1)<<p[i]; 
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/csdn_47/article/details/69258260