PAT(A-LEVEL) 1002. A+B for Polynomials

1002. A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2


水题不解释


#include<cstdio>
#define MAX 1001
using namespace std;

int main()
{
    int k,n;
    int count=0;    //记录有多少个系数不为0的项 
    float a[MAX]={0.0},b[MAX]={0.0},c[MAX]={0.0};

    //分别读入第一行与第二行 
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d",&n);
        scanf("%f",&a[n]);
    } 
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d",&n);
        scanf("%f",&b[n]);
    } 

    for(int i=0;i<MAX;i++){
        c[i]=a[i]+b[i];
        if(c[i]!=0) count++; 
    } 

    printf("%d",count);
    for(int i=MAX-1;i>=0;i--){
        if(c[i]!=0) printf(" %d %.1f",i,c[i]);
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29159273/article/details/53984925