Play the Dice——(数学)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/weixin_44056753/article/details/100100566

There is a dice with n sides, which are numbered from 1,2,…,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What’s more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.

Input

Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.

Output

Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.

Sample Input

6 1 2 3 4 5 6
0
4 0 0 0 0
1 3

Sample Output

3.50
0.00

/* HDU - 4586 */

题意

给你一个n个面的骰子,然后每个面上都有特定的值,你有一次机会抛骰子,你可以获得朝上那面的值的分数。n面骰子 中有m面是特殊的面,当你抛到这些特殊的面的时候,你可以再抛一次骰子。问你最后获得分数的期望是多少。ps 抛到每一面的机会都是相等的。

思路

如果所有面的分数之和为sum,我们可以知道,每一次的得分期望是sum/n,并且每一次抛到特殊面的概率为m/n,这样我们就得到了他们的概率,1+m/n+(m/n)^2+(m/n) ^t;t趋向于正无穷。这样这个问题就转换成了求上述无穷级数的收敛值的问题。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<map>
#include<ctime>
#include<vector>
#include<cstring>
#include<iomanip>
using namespace std;
int main()
{
    int n,m,sum,k;
    while (cin>>n)
    {
        sum = 0;
        for (int i = 0; i < n; i++)
        {
            cin>>k;
            sum += k;
        }
        cin>>m;
        for (int i = 0; i < m; i++)
        cin>>k;
        if (sum == 0)
        {
            puts("0.00");
            continue;
        }
        if (m >= n)
        {
            puts("inf");
        }
        else
            printf("%.2f\n", 1.0 * sum / (n - m));
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_44056753/article/details/100100566