PAT A1070

  • 题目:
    Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).
Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

  • 解题思路
    1.新建一个结构,里面包含存储量,总利润,平均利润,之后按照平均利润从大到小排序
    2.若需求量大于一种月饼的存储量,则总利润加上这种月饼的全部利润。否则总利润加上还需要的月饼量所能产生的利润,并跳出循环

代码实现:

#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstdio>
using namespace std;
struct mon{
    double stor;
    double price;
    double ava;
}num[1010];
bool cmp(mon a, mon b){          //按照平均利润从大到小排序
    return a.ava > b.ava;
}
int main()
{
    int kind;
    double need;    //月饼的种类和月饼的需求
    double sum;
    cin>> kind >>need;
    for(int i = 0; i < kind; i++){
        cin >> num[i].stor;
    }
    for(int i = 0; i < kind; i++){
        cin >> num[i].price;
    }
    for(int i = 0; i < kind; i++)
        num[i].ava = num[i].price / num[i].stor;
    sort(num, num+kind, cmp);
    for(int i = 0; i < kind; i++){
        if(num[i].stor < need){
            sum += num[i].price;
            need -= num[i].stor;
        }
        else{
            sum += num[i].ava * need;
            break;
        }
    }
    printf("%.2f",sum);
    //cout <<setiosflags(ios::fixed) <<setprecision(2);
    //cout << sum;
    return 0;

}

猜你喜欢

转载自blog.csdn.net/xiao1guaishou/article/details/88558422