PAT:A1070 Mooncake (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Ecloss/article/details/82664633

PAT:A1070 Mooncake (25 分)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

代码:

// 第一步:构造体写好,库存,总售价,单价
// 第二步:按照单价进行从大到小排序
// 第三步:循环,然后进行判断
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

const int maxn = 1010;
struct Cake{
	double stock;	// 库存
	double total;	// 总售价
	double price;	// 单价 
}cake[maxn]; 

bool cmp(Cake a, Cake b) {
	return a.price > b.price;
}

int main() {
	// N--月饼种类, D:总需求量
	int N;
	double D;
	// 最关键的一步:输入N, 和D
	scanf("%d %lf", &N, &D); 
	// 第一步:将月饼库存量循环存储到cake的stock
	for(int i = 0; i < N; i++) {
		scanf("%lf", &cake[i].stock);
	}
	// 第二步:输入每个月饼的总售价
	for(int i = 0; i < N; i++) {
		scanf("%lf", &cake[i].total);
		cake[i].price = cake[i].total / cake[i].stock;
	}
	// 第三步:按照单价排序
	sort(cake, cake+N, cmp);
	// 第四步:获得最大利润
	double money = 0;
	for(int i = 0; i < N; i++) {
		if(D >= cake[i].stock) {
			money += cake[i].total;
			D -= cake[i].stock;
		} else {
			money += cake[i].price*D;
			break;
		}
	}
	printf("%.2f", money);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Ecloss/article/details/82664633
今日推荐