L2-006 树的遍历 (递归建树)(25 分)

L2-006 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

代码

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
struct BinTree
{
    int val;
    BinTree *left, *right;
};
vector<int> post, in;
BinTree* BuildTree(BinTree *root, int inl, int inr, int pl, int pr)
{
    if(inl > inr || pl > pr)
        return nullptr;
    root = new BinTree;
    root->val = post[pr];
    root->left = root->right = nullptr;
    int mid = -1;
    for(int i=inl;i<=inr;i++)
    {
        if(in[i] == root->val)
        {
            mid = i;
            break;
        }
    }
    int nleft = mid - inl;
    root->left = BuildTree(root->left, inl, inl+nleft-1, pl, pl+nleft-1);
    root->right = BuildTree(root->right, mid+1, inr, pl+nleft, pr-1);
    return root;
}
void layer_order(BinTree *root)
{
    queue<BinTree*> q;
    vector<int> ans;
    if(root == nullptr)
        return ;
    q.push(root);
    while(!q.empty())
    {
        BinTree *node = q.front();q.pop();
        ans.push_back(node->val);
        if(node->left)
            q.push(node->left);
        if(node->right)
            q.push(node->right);
    }
    for(int i=0;i<ans.size();i++)
    {
        if(i!=0)
            cout << " ";
        cout << ans[i];
    }
}
int main()
{
    int n;
    cin >> n;
    post.resize(n);
    in.resize(n);
    for(int i=0;i<n;i++)
    {
        cin >> post[i];
    }
    for(int i=0;i<n;i++)
    {
        cin >> in[i];
    }
    BinTree *root = nullptr;
    root = BuildTree(root, 0, n-1, 0, n-1);
    layer_order(root);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43264529/article/details/88812015