团体天梯 L2-006 树的遍历 (25 分)(STL层序遍历、运行流程)

版权声明:有疑问请在评论区回复,邮箱:[email protected] https://blog.csdn.net/qq_40946921/article/details/88065631

L2-006 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

根据后序和中序遍历建树的程序步骤:

    1、从后序遍历中取最后一个结点

    2、在中序遍历中找到该结点

    3、以该结点为界线,将中序遍历一分为二,得到两个中序序列

    4、根据中序的分组,再回到后序遍历中将之一分为二,得到两个后序序列

    5、对于每个非空序列,回到第一步,继续执行

如果你想深入了解运行流程,可以加入print函数,恢复被我注释掉的print

print函数:

void print(Order order) {
	cout << "\n中序: ";
	for (auto it : order.mid)
		cout << it << " ";
	cout << "\n后序: ";
	for (auto it : order.post)
		cout << it << " ";
	cout << endl;
}

代码: 

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
struct Order {
	vector<int> post, mid;
};
void creat(Order order) {
	queue<Order> tree;
	tree.push(order);
	while (!tree.empty()) {
		Order left, right;
		int  key = tree.front().post.back(), flag = 0;
	//print(tree.front());
		for (int i = 0, j = 0; i < tree.front().mid.size() && j < tree.front().post.size() - 1;) {
			if (tree.front().mid[i] == key) {
				i++; flag = 1;
			}
			else {
				(flag ? right : left).mid.push_back(tree.front().mid[i++]);
				(flag ? right : left).post.push_back(tree.front().post[j++]);
			}
		}
		if (!left.post.empty())			tree.push(left);
		if (!right.post.empty())		tree.push(right);
		tree.pop();
		cout << key << (tree.empty() ? "" : " ");
	}
}
int main() {
	int n, tmp;
	Order order;
	cin >> n;
	for (int i = 0; i < 2 * n; i++) {
		cin >> tmp;
		(i < n ? order.post: order.mid ).push_back(tmp);
	}
	creat(order);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40946921/article/details/88065631