L2-006 树的遍历

L2-006 树的遍历
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:

4 1 6 3 5 7 2
解题思路:
参照晴神书,通过后序和中序建树,再用BFS进行层序输出。
但是在柳神博客中看到可以不建树的方法。

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=50;
struct node{
    int data;
    node *lchild,*rchild;
};
int n;
int post[maxn],in[maxn],pre[maxn];
//后序、中序建树 
node *creat(int postl,int postr,int inl,int inr){
    if(postl>postr)
        return NULL;
    node *root=new node;
    root->data=post[postr];
    int k;
    for(k=inl;k<=inr;k++){
        if(in[k]==post[postr])
            break;
    }
    int numleft=k-inl;
    root->lchild=creat(postl,postl+numleft-1,inl,k-1);
    root->rchild =creat(postl+numleft,postr-1,k+1,inr);
    return root;
}
//层序输出 
int num=0;
void bfs(node *root){
    queue<node*>q; //队列里要存地址 
    q.push(root) ;
    while(!q.empty()  ){
        node *top=q.front() ;   //这里要加* 
        q.pop() ;
        printf("%d",top->data );
        num++;
        if(num<n) printf(" ");
        if(top->lchild !=NULL) q.push(top->lchild ) ;
        if(top->rchild !=NULL) q.push(top->rchild ) ;
    }
}
int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&post[i]);
    }
    for(int i=0;i<n;i++){
        scanf("%d",&in[i]);
    }
    node *root=creat(0,n-1,0,n-1);
    bfs(root);
    return 0;

}

猜你喜欢

转载自blog.csdn.net/chenyutingdaima/article/details/81260118