L2-006 树的遍历 (25分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

很经典的一道树的题,考了树和队列的知识,首先根据给出的后续和中序还原出二叉树(后续寻找根节点,中序区分左右子树),然后根据队列的知识,依次输出层次遍历的结果。

#include <iostream>
#include <string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include <vector>
#include <map>
#include<queue>
using namespace std;
typedef struct Node{
    
    
	int data;
	struct Node *left,*right;
}Node,*Tree;
Tree create(int n,int *aft,int *mid){
    
    //创建树,递归就完了
	if(n==0){
    
    
		return NULL;
	}
    Tree tree=(Tree)malloc(sizeof(Node));
    tree->data=aft[n-1];//找到根节点
    tree->left=tree->right=NULL;
    int i;
    for( i=0;mid[i]!=aft[n-1];i++);
    tree->left=create(i,aft,mid);//找到左子树
    tree->right=create(n-1-i,aft+i,mid+i+1);//找到右子树
    return tree;//返回树
}
void order(int n,Tree tree){
    
    
	if(!tree){
    
    //如果是空树,直接返回
		return ;
	}
	queue<Tree>qu;//创建队列
	qu.push(tree);//将根节点压入队列
	int len=0;
	while(!qu.empty()){
    
    
		Tree t=qu.front();//设定指针
		len++;
		if(len<n){
    
    
			cout<<t->data<<" ";
		}
		else{
    
    
			cout<<t->data;
		}
		if(t->left){
    
    
			qu.push(t->left);
		}
		if(t->right){
    
    
			qu.push(t->right);
		}
		qu.pop();
	}
}
int main() {
    
    
	ios::sync_with_stdio(false);
	int n;
	cin>>n;
	int aft[n],mid[n];
	for(int i=0;i<n;i++){
    
    
		cin>>aft[i];//后续
	}
	for(int i=0;i<n;i++){
    
    
		cin>>mid[i];//中序
	}
	Tree tree=create(n,aft,mid);
	order(n,tree);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45962741/article/details/113443426