大数同余应用

大数同余的简单介绍

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
char s[220];
int main()
{
    int T,Case = 1;
    scanf("%d",&T);
    ll b;
    while(T--)
    {
        scanf("%s %lld",s,&b);
        int len = strlen(s);
        ll sum = 0;
        b = abs(b);
        for(int i = 0; i < len; i++)
        {
            if(s[i] == '-')
                continue;
            sum = ( sum*10+ (s[i]-'0') )%b;
        }
        if(!sum)
            printf("Case %d: divisible\n",Case++);
        else
            printf("Case %d: not divisible\n",Case++);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Nothing_227/article/details/82867687