[负数dp] poj 2184 Cow Exhibition

Cow Exhibition

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16472   Accepted: 6730

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 
The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 
Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 
Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 


这个题目问的是奶牛聪明和乐趣之和,最大值可以为多大。用简单的01背包dp来实现,其中聪明值为数组的维度,乐趣为数组的值。其中比较麻烦一点的是聪明值(数组维度)可以为负值。那我们把所有的聪明值加10000,将所有的聪明值变为正数,存放在数组中。

当聪明值为正数时,就是普通的01背包,从后往前遍历。负值时,从前往后遍历。

#include <bits/stdc++.h>
#define inf 0x3f3f3f
#define sh 10000
#define N 200005
#define max(a,b) (a > b ? a : b)

using namespace std;

struct node{
	int v,w;
}a[105];

int dp[N];

int main(){
	int n;
	cin >> n;
	for(int i=0;i<n;i++)
		cin >> a[i].v >> a[i].w;
	memset(dp,-inf,sizeof(dp));
	dp[sh] = 0;
	for(int i=0;i<n;i++){
		if(a[i].v > 0){
			for(int k=N-1;k>=a[i].v;k--){
				dp[k] = max(dp[k-a[i].v] + a[i].w,dp[k]);
			}	
		}
		else{
			for(int k=0;k<N+a[i].v;k++){
				dp[k] = max(dp[k-a[i].v] + a[i].w,dp[k] );
			}
		}
	}
	int ans = 0;
	for(int i=sh;i<N;i++){
		if(dp[i]>0){
			ans = max(ans,i-sh+dp[i]);
		}
	}
	cout << ans << endl;
}

猜你喜欢

转载自blog.csdn.net/qq_40738689/article/details/88774031