Cow Exhibition (负数01背包)

"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input
* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output
8
Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.


题意:选取任意组使得左边相加大于零,右边相加也大于零,最终的和最大

#include<iostream>
#include<cstring>
using namespace std;
#define MT(a,b) memset(a,b,sizeof(a))
#define ll long long
const int maxn = 2e5+5;

int main()
{
    int n;cin>>n;
    int s[200],p[200];MT(s,0);MT(p,0);
    for(int i=0;i<n;i++)cin>>s[i]>>p[i];
    int f[maxn];
    for(int i=0;i<maxn;i++)f[i]=-100000;//因为有负数,所以赋值最小
    f[100000]=0;//平移零点
    for(int i=0;i<n;i++)
    {
        //正数方向遍历,正向遍历 ,为了避免重复
        if(s[i]>=0)
        {
            for(int j=maxn-1;j>=s[i];j--)
                f[j]=max(f[j-s[i]]+p[i],f[j]);
        }
        else
        {
            for(int j=0;j<=maxn-1+s[i];j++)
                f[j]=max(f[j-s[i]]+p[i],f[j]);
        }
    }
    int ans=0;
    for(int i=100000;i<=maxn-1;i++)//从零点开始查找最大值
    {
        if(f[i]>0)ans=max(ans,f[i]+i-100000);
    }
    cout<<ans<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Mannix_Y/article/details/80996871