POJ 2184 Cow Exhabition

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 
 
显然是个0/1背包 把 s 当做体积,f 当做重量就可以。
 但是问题在于物品的体积有负数。
一般情况下,我们做的背包都是体积在一个以 0 为左端点的区间。
这道题变成了 一个 -1000*100 到 1000*100 的区间,我们可以将这个区间整体向右平移 100000
这样的话 原点移动到了 100000 这个点。左端点从 -1000*100 变成了 0
然后再分类讨论 s 的正负,进而决定是从大到小还是从小到大dp
 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int inf = 1<<30;
const int dir = 100000;
int dp[200005];
struct s{
    int s, f;
}arr[105];

int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d%d",&arr[i].s,&arr[i].f);
    
    for(int i=0;i<=200000;i++)
        dp[i] = -inf;
    dp[100000] = 0;
    
    for(int i=0;i<n;i++){
        if(arr[i].s < 0 && arr[i].f < 0)
            continue;
        if(arr[i].s>0){
            for(int j=200000;j>=arr[i].s;j--){
                if(dp[j-arr[i].s] > -inf){
                    dp[j] = max(dp[j],dp[j-arr[i].s]+arr[i].f);
                }
            }

        }else {// arr[i].s < 0  arr[i].f>=0
            for(int j=arr[i].s;j<=200000+arr[i].s;j++){
                if(dp[j-arr[i].s] > -inf){
                    dp[j] = max(dp[j],dp[j-arr[i].s]+arr[i].f);
                }
            }
        }
    }
    int ans = 0;
    for(int i=100000;i<=200000;i++){
        if(dp[i]>=0)
            ans = max(ans, dp[i]+i-100000);
    }
    printf("%d\n",ans);
    return 0;
}
View Code
 

猜你喜欢

转载自www.cnblogs.com/kongbb/p/10452901.html