poj2184负数01背包

Cow Exhibition

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions:16528   Accepted: 6748

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 
 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source

USACO 2003 Fall

#include<iostream>
#include<cstdio>
#include<algorithm>
#define inf 0x3f3f3f3f
#define maxm 200005
#define maxn 205
using namespace std;
int w[maxn];
int c[maxn];
int dp[maxm];
int n;
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d",&w[i],&c[i]);
        for(int i=0;i<=200000;i++)
            dp[i]=-inf;
            dp[100000]=0;
        for(int i=1;i<=n;i++)
        {if(w[i]>=0)
            {for(int j=200000;j>=w[i];j--)
                dp[j]=max(dp[j-w[i]]+c[i],dp[j]);


            }


        else
        {
            for(int j=0;j<=200000+w[i];j++)
                dp[j]=max(dp[j-w[i]]+c[i],dp[j]);
        }
    }
    int ans=0;
    for(int i=100000;i<=200000;i++)
        if(dp[i]>0)
        ans=max(ans,dp[i]+i-100000);
        printf("%d\n",ans);
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89056547