7-9 红色警报 (25 分)

战争中保持各个城市间的连通性非常重要。本题要求你编写一个报警程序,当失去一个城市导致国家被分裂为多个无法连通的区域时,就发出红色警报。注意:若该国本来就不完全连通,是分裂的k个区域,而失去一个城市并不改变其他城市之间的连通性,则不要发出警报。

输入格式:

输入在第一行给出两个整数N(0 < N ≤ 500)和M(≤ 5000),分别为城市个数(于是默认城市从0到N-1编号)和连接两城市的通路条数。随后M行,每行给出一条通路所连接的两个城市的编号,其间以1个空格分隔。在城市信息之后给出被攻占的信息,即一个正整数K和随后的K个被攻占的城市的编号。

注意:输入保证给出的被攻占的城市编号都是合法的且无重复,但并不保证给出的通路没有重复。

输出格式:

对每个被攻占的城市,如果它会改变整个国家的连通性,则输出Red Alert: City k is lost!,其中k是该城市的编号;否则只输出City k is lost.即可。如果该国失去了最后一个城市,则增加一行输出Game Over.

输入样例:

5 4
0 1
1 3
3 0
0 4
5
1 2 0 4 3

输出样例:

City 1 is lost.
City 2 is lost.
Red Alert: City 0 is lost!
City 4 is lost.
City 3 is lost.
Game Over.

 代码如下:

#include<bits/stdc++.h>
using namespace std;
#define size 505
typedef int U[size];
typedef struct
{
	int x;
	int y;
}Road;
void Init(U& S,int n)
{
	for (int i = 0; i < n; i++)S[i] = -1;
}
int Find(U S,int x)
{
	while (S[x] >= 0)x = S[x];
	return x;
}
void MergebWeight(U& S, int x, int y)
{
	int i = Find(S, x), j = Find(S, y);
	if (i != j)
	{
		int temp = S[i] + S[j];
		if (S[i] < S[j])
		{
			S[j] = i;
			S[i] = temp;
		}
		else
		{
			S[i] = j;
			S[j] = temp;
		}
	}

}
int CollapsingFind(U S, int i)
{		
	int k, temp;
	for (k = i; S[k] >= 0; k = S[k]);
	while (i != k)
	{
		temp = S[i]; S[i] = k; i = temp;

	}
	return k;
}
int main()
{
	int N, M;
	cin >> N >> M; 

	U f;
	Init(f, N);

	vector<Road>r;
	for (int i = 0; i < M; i++)
	{
		int a, b;
		cin >> a >> b;

		Road t;
		t.x = a; t.y = b;
		r.push_back(t);

		MergebWeight(f, a, b);
	}

	map<int, int>mp;
	int sum = 0;
	for (int i = 0; i < N; i++)
	{	

		int temp = CollapsingFind(f, i);
		if (!mp.count(temp))
		{		
			mp[temp] = 1;
			sum++;
		}
	}

	int K, num;
	cin >> K;
	
	int vis[505] = { 0 };
	for (int i = 0; i < K; i++)
	{	
		Init(f, N);
		cin >> num;
		vis[num] = 1;
		for (int i = 0; i < M; i++)
		{
			if (vis[r[i].x] == 1 ||vis[r[i].y] == 1)
				continue;
			MergebWeight(f, r[i].x, r[i].y);
		}

		mp.clear();
		int cnt = 0;
		for (int i = 0; i < N; i++)
		{
			int temp = CollapsingFind(f, i);
			if (!mp.count(temp))
			{
				mp[temp] = 1;
				cnt++;
			}
		}
		if (cnt - 1 == sum || cnt == sum)
			printf("City %d is lost.\n", num);
		else
			printf("Red Alert: City %d is lost!\n", num);
		sum = cnt;
	}
	if (K >= N)
		printf("Game Over.\n");

	return 0;
}

猜你喜欢

转载自blog.csdn.net/TOBEALISTENNER/article/details/88647213
今日推荐