7-9 抢红包(25 分)

7-9 抢红包(25 分)
没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。

输入格式:

输入第一行给出一个正整数N(≤10
​4
​​ ),即参与发红包和抢红包的总人数,则这些人从1到N编号。随后N行,第i行给出编号为i的人发红包的记录,格式如下:

​​ K N1 P1 ⋯N​K PK
​​
其中K(0≤K≤20)是发出去的红包个数,N
​i
​​ 是抢到红包的人的编号,P
​i
​​ (>0)是其抢到的红包金额(以分为单位)。注意:对于同一个人发出的红包,每人最多只能抢1次,不能重复抢。

输出格式:

按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

输入样例:

10
3 2 22 10 58 8 125
5 1 345 3 211 5 233 7 13 8 101
1 7 8800
2 1 1000 2 1000
2 4 250 10 320
6 5 11 9 22 8 33 7 44 10 55 4 2
1 3 8800
2 1 23 2 123
1 8 250
4 2 121 4 516 7 112 9 10
输出样例:

1 11.63
2 3.63
8 3.63
3 2.11
7 1.69
6 -1.67
9 -2.18
10 -3.26
5 -3.26
4 -12.32

这个题运用C++里面内置排序的函数Sort(),通过对运算符重载,可以很简单的快速的实现排序,相比C语言来说,我们可以实现的更快和更高效,如果用C语言实现的话,我们还要自己学排序,自己来构造函数,相对来说比较复杂。

#include<bits/stdc++.h>
using namespace std;
typedef struct node{
     double money;
     int count;
     int id;
}nodeOne;
int cmp(nodeOne A,nodeOne B){
    if(A.money!=B.money){
        return A.money>B.money;
    }if(A.count!=B.count){
        return A.count>B.count;
    }if(A.id!=B.id){
        return A.id<B.id;
    }
}
int main(){
    int b,c;
    nodeOne a[10005];
    cin>>b;
    for(int i=0;i<=b;i++){
        a[i].count=0;
        a[i].id=i;
        a[i].money=0;
    }

    for(int i=1;i<=b;i++){
        cin>>c;
        int id;
        double sum=0,sumTwo=0;
        for(int j=1;j<=c;j++){
            cin>>id>>sum;
            a[id].id=id;
            a[id].money+=(sum/100.0);
            a[id].count++;
            sumTwo+=sum;
        }
        a[i].money-=sumTwo/100.0;
     }
    sort(a+1,a+b+1,cmp);
    for(int i=1;i<=b;i++){
        printf("%d %.2f\n",a[i].id,a[i].money);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_38505045/article/details/80163738