HDU 1213 How Many Tables

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

#include<stdio.h>
int main(void)
{
    int T,N,M,group[1005],i,a,b;
    
    scanf("%d",&T);
    
    while(T--)
    {
        
        scanf("%d%d",&N,&M);
     
     for(i=1;i<=N;i++)                  //  预先   分成 N个 桌子 
      group[i]=i;
      
      for(i=1;i<=M;i++)
      {
          
          scanf("%d%d",&a,&b);
          while(group[a]!=a)             //为什么会 group[a]!=a 呢???? 
           a=group[a];                  //  
                                          
                                          /*
                                                要理解   为什么会 group[a]!=a
                                                 就要先明白  并查集

                                                 再说白一点,这一步 是一个 套路

                                              是为下面 这句 代码 做铺垫的

  i                                                        f(a!=b)
                                                               {
                                                                 group[b]=group[a];
                                                                  N--;
                                                                 }
                                                         这样就很好明白了。。。。。。。。

          顺便再说一句,初学者多模仿别人的代码,很有帮助,能少走很多弯路。
                                        */ 
           while(group[b]!=b)            //为什么会 group[b]!=b 呢????
           b=group[b];                  //  
           
           if(a!=b)
           {
               group[b]=group[a];
               N--;
           }
      }
        
       printf("%d\n",N);     
    }
    
    return 0;
 } 
 
 
 //就一个简单的并查集
  

猜你喜欢

转载自blog.csdn.net/S_999999/article/details/81089702
今日推荐