A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 412670    Accepted Submission(s): 79964


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
 
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1000  1001  1004  1003  1008 

//输出格式错误  提交了好多次,然来两组数据之间还需要换行的。

#include<iostream>
#include<string>
#include<string.h>
#include<cstdio>
using namespace std;
int max(int a,int b)
{
    if(a>b)  return a;
    else  return b;
}
int main()
{
    int e,p;
    cin>>e;
    char m[1005];
    char n[1005];
    int a[1005];
    int b[1005];
    for(p=1;p<=e;p++)
    {
        cin>>m>>n;
        int i,t,x,y,len,j=0,q;
        for(t=0;t<1005;t++)
        {
            a[t]=0;
            b[t]=0;
        }
        x=strlen(n);
        y=strlen(m);
        for(i=x-1;i>=0;i--)
            a[j++]=n[i]-'0';
        j=0;
        for(i=y-1;i>=0;i--)
            b[j++]=m[i]-'0';
        len=max(x,y);
        for(i=0;i<len;i++)
        {
            a[i]+=b[i];
            a[i+1]+=a[i]/10;
            a[i]%=10;
        }
        for(i=1004;i>=0;i--)
        {
            if(a[i]!=0)
            {
                q=i;
                break;
            }
        }
        cout<<"Case "<<p<<":"<<endl;
        printf("%s + %s = ",m,n);
        for(i=q;i>=0;i--)
            cout<<a[i];
        cout<<endl;
        if(p!=e) cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hujinhong145/article/details/80086561
今日推荐