A + B Problem II(大数问题)

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
 
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
用字符串做:
#include<stdio.h>
#include<string.h>
char str1[1005],str2[1005],str[1005];
int main(){
    int t;
    while(scanf("%d",&t)!=EOF){
    //scanf("%d",&t);
    getchar();
    int cases=1;
    while(t--){
        if(cases!=1)
            printf("\n");
        scanf("%s%s",str1,str2);
        int i,j,temp=0,k=0;
        int len1=strlen(str1),len2=strlen(str2);
        for(i=len1-1,j=len2-1;i>=0 && j>=0;i--,j--){
            temp+=(str1[i]-'0')+(str2[j]-'0');
            str[k++]=(temp+'0');
            temp/=10;
        }
        if(i<0 && j<0 && temp!=0)
            str[k++]=(temp+'0');
        while(i>=0){
            temp+=(str1[i--]-'0');
            str[k++]=(temp+'0');
            temp/=10;
        }
        while(j>=0){
            temp+=(str2[j--]-'0');
            str[k++]=temp+'0';
            temp/=10;
        }
        if(temp!=0)
            str[k++]=(temp+'0');
        printf("Case %d:\n",cases);
        printf("%s + %s = ",str1,str2);
        for(i=k-1;i>0;i--)
            printf("%c",str[i]);
        printf("%c\n",str[i]);
        cases++;
    }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/u013514659/article/details/21885373
今日推荐