Problem B: 字符串类(II)

 

Problem B: 字符串类(II)

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 6103  Solved: 2687
[Submit][Status][Web Board]

Description

封装一个字符串类,用于存储字符串和处理的相关功能,支持以下操作:

1. STR::STR()构造方法:创建一个空的字符串对象。

2. STR::STR(const char *)构造方法:创建一个字符串对象,串的内容由参数给出。

3. STR::length()方法:返回字符串的长度。

4. STR::putline()方法:输出串的内容,并换行。

5. 运算符“+”和“+=”,表示两个字符串的连接运算,规则为:

   c = a + b 表示串c中的字符是a和b的连接:“a+b”的结果是一个新的字符串,串a和串b的内容不变。

   a += b    表示串a中的字符是a和b的连接:串b中的内容不变

-----------------------------------------------------------------------------

你设计一个字符串类STR,使得main()函数能够正确运行。

函数调用格式见append.cc。

append.cc中已给出main()函数。

-----------------------------------------------------------------------------

Invalid Word(禁用单词)错误:“string”、“vector”等被禁用。

Input

输入有若干行,每行一个字符串。

Output

每组测试数据对应输出一行,包含两部分内容,首先是一个整数,表示输入串的长度,然后是输入的字符串,两者用一个空格分开。格式见sample。

Sample Input

A
123456789

Sample Output

12 Hello World!
0 
12 Hello World!
12 Hello World!
12 Hello World!
10 A123456789
1 A
9 123456789
10 123456789A
1 A

  

HINT

 

Append Code

int main()
{
    STR e;
    STR h("Hello World!");
    STR he = e + h;
    cout << he.length() << " ";
    he.putline();
    cout << e.length() << " ";
    e.putline();
    cout << h.length() << " ";
    h.putline();
    e += h;
    cout << e.length() << " ";
    e.putline();
    cout << h.length() << " ";
    h.putline();

    char s1[100001], s2[100001];
    while(gets(s1) != NULL && gets(s2) != NULL)
    {
        STR str1(s1), str2(s2);
        STR str = str1 + str2;
        cout << str.length() << " ";
        str.putline();
        cout << str1.length() << " ";
        str1.putline();
        cout << str2.length() << " ";
        str2.putline();
        str2 += str1;
        cout << str2.length() << " ";
        str2.putline();
        cout << str1.length() << " ";
        str1.putline();
    }
}

  

#include <iostream>
#include <iomanip>
#include <cstdlib>
#include <cstdio>
using namespace std;
int getlength(const char *arr)
{
    int l=0;
    for(int i=0; arr[i]!='\0'; i++)
        l++;
    return l;
}
void copystring(char *arr, const char *brr)
{
    int l=getlength(brr);
    for(int i=0; i<l; i++)
        arr[i]=brr[i];
        arr[l]='\0';
}
class STR
{
public :
    char *arr;
    int l;
    int ll;
    STR():arr(NULL),l(0),ll(0){}
    STR(const char *brr)
    {
        l=getlength(brr);
        ll=l*2;
        arr=new char[ll];
        copystring(arr,brr);
    }
    int length()
    {
        return l;
    }
    void putline()
    {
        for(int i=0; i<l; i++)
            cout<<arr[i];
        cout<<endl;
    }
    friend STR operator+(const STR &p1, const STR &p2)
    {

        STR temp;
        temp.l=p1.l+p2.l;
        temp.ll=temp.l*2;
        temp.arr=new char[temp.ll];
        int i;
        for(i=0; i<p1.l; i++)
            temp.arr[i]=p1.arr[i];
        for(int j=i; j<i+p2.l; j++)
        {
            temp.arr[j]=p2.arr[j-i];
        }
        temp.arr[temp.l]='\0';
        return temp;

    }
    STR operator+=(const STR &p2)
    {
        int length=l+p2.l;
        ll=length*2;
        char *brr;
        brr=new char[ll];
        int i;
        for(i=0; i<l; i++)
        {
           brr[i]=arr[i];
        }
        for(int j=l; j<p2.l+l; j++)
        {
            brr[j]=p2.arr[j-l];
        }
            brr[length]='\0';
            delete []arr;
            arr=brr;
            //delete []brr;
            return *this;
    }
    ~STR()
    {
        //delete []arr;// 不能析构!!!!!
        //在+= 运算中如果析构了就没法调用使用了,就会乱码!!!!
    }
};
int main()
{
    STR e;
    STR h("Hello World!");
    STR he = e + h;
    cout << he.length() << " ";
    he.putline();
    cout << e.length() << " ";
    e.putline();
    cout << h.length() << " ";
    h.putline();
    e += h;
    cout << e.length() << " ";
    e.putline();
    cout << h.length() << " ";
    h.putline();

    char s1[100001], s2[100001];
    while(gets(s1) != NULL && gets(s2) != NULL)
    {
        STR str1(s1), str2(s2);
        STR str = str1 + str2;
        cout << str.length() << " ";
        str.putline();
        cout << str1.length() << " ";
        str1.putline();
        cout << str2.length() << " ";
        str2.putline();
        str2 += str1;
        cout << str2.length() << " ";
        str2.putline();
        cout << str1.length() << " ";
        str1.putline();
    }
}

  

猜你喜欢

转载自www.cnblogs.com/Jie-Fei/p/9126344.html
今日推荐