【大数】A + B Problem II

描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

输入

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

输出

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

样例输入

2
1 2
112233445566778899 998877665544332211

样例输出

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

分析:大数相加。
代码:
#include<bits/stdc++.h>
using namespace std;
string a,b;
int T;
int f[1010],A[1010],B[1010];
int main()
{
cin>>T;
for (int W=1;W<=T;W++)
{
cin>>a>>b;
int l,la=a.length(),lb=b.length();
for (int i=0;i<1010;i++)
A[i]=B[i]=f[i]=0;
cout<<"Case "<<W<<’:’<<endl;
for (int i=0;i<la;i++)
A[i]=a[la-i-1]-‘0’;
for (int i=0;i<lb;i++)
B[i]=b[lb-i-1]-‘0’;
int lm=max(la,lb);
int k=0,h=0,i;
for (i=0;i<lm;i++)
{
h=A[i]+B[i]+k;
f[i]=h%10;
k=h/10;
}
if (k!=0) f[i++]=k;
l=1009;
while(f[l]0) l–;
cout<<a<<" + “<<b<<” = ";
if (a[0]
‘0’&&b[0]==‘0’) cout<<0;
for (int j=l;j>=0;j–)
cout<<f[j];
cout<<endl;
if (W!=T) cout<<endl;
}
return 0;
}

发布了40 篇原创文章 · 获赞 0 · 访问量 669

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/103653070
今日推荐