HDU 1002 ( A + B Problem II )

版权声明:本人原创,转载请注明出处! https://blog.csdn.net/qq_29117927/article/details/82078239
                                        A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 430165 Accepted Submission(s): 83626

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
long int max(long int c,long int d)
{
    if(c>d)
        return c;
    else
        return d;
}
int main()
{
    long int n,m,i,t,x,y,j=0;
    char a[10000],b[10000],c[10001];
    scanf("%ld",&n);
    while(n--)
    {
        scanf("%s",a);
        scanf("%s",b);
        j++;
        x=strlen(a);
        y=strlen(b);
        t=max(x,y);
        for(i=0;i<=t;i++)
            c[i]='0';
        for(i=0;i<t;i++)
        {
            if((x-1-i)>=0&&(y-1-i)>=0)
                m=a[x-1-i]+b[y-1-i]-96;
            else
            {
                if((x-1-i)<0&&(y-1-i)>=0)
                    m=b[y-1-i]-48;
                else
                {
                    if((x-1-i)>=0&&(y-1-i)<0)
                        m=a[x-1-i]-48;
                }
            }
            if(m>=10)
            {
                c[t-1-i]=c[t-1-i]+1;
                c[t-i]=c[t-i]+(m-10);
            }
            else
            {
                if((c[t-i]-48+m)>=10)
                {
                    c[t-1-i]=c[t-1-i]+1;
                    c[t-i]=c[t-i]+(m-10);
                }
                else
                {
                    c[t-i]=c[t-i]+m;
                }
            }
        }
        printf("Case %d:\n",j);
        printf("%s + %s = ",a,b);
        if(c[0]!='0')
            printf("%c",c[0]);
        for(i=1;i<=t;i++)
        {
            printf("%c",c[i]);
        }
        printf("\n");
        if(n!=0)
        {
            printf("\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29117927/article/details/82078239
今日推荐