HDU-1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4112 Accepted Submission(s): 1434
 
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output

            For each test case, you should output two lines. The first line is \\\\\\\"Case #:\\\\\\\", # means the number of the test case. The second line is the an equation \\\\\\\"A + B = Sum\\\\\\\", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

今天很懵,一开始Java疯狂编译错误,WA,后来发现长度是1000,改用c来做;继续疯狂WA,这个题目这样都wa,我怕是傻子哟,最后发现一个参数弄错了。。。chiou;

除了中间的ac,其他都是我(微笑)

代码如下:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
char a[1005];
char b[1005];
int c[1005];
int main()
{
	int t,lena,lenb,lenc;
	cin>>t;
	for(int i=1;i<=t;i++)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		int j;
		scanf("%s%s",a,b);
		lena=strlen(a)-1;
		lenb=strlen(b)-1;
		int index=0;
		while(lena>=0&&lenb>=0)
		{
			c[index]=(c[index]+a[lena]+b[lenb]-'0'-'0');
			c[index+1]=c[index]/10;
			c[index]=c[index]%10;
			lena--;
			lenb--;
			index++;
		}
		while(lena>=0)
		{
			c[index++]+=a[lena--]-'0';
		}
		while(lenb>=0)
		{
			c[index++]+=b[lenb--]-'0';
		}
		printf("Case %d:\n",i);
		printf("%s + %s = ",a,b);
		for(int l=index;l>=0;l--)
		{
			if(c[l]==0&&l==index)
			continue;
			printf("%d",c[l]);
		}
		printf("\n");
		if(i<t)
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41049440/article/details/80890769
今日推荐