HDU - 1002 A + B Problem II

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
解题思路:
就是模拟加法

c[j]=a[len1]+b[len2]-'0'+k;
 if(c[j]>'9') 
 {
    
    
     c[j]=c[j]-10;
     k=1;
 }

注意:逆序输出时要注意过滤前导零。

#include<stdio.h>
#include<string.h>
char a[10000],b[10000];
char c[1000001];
int main()
{
    
    
    int n=0,i=0;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
	{
    
    
        scanf("%s %s",a,b);
        printf("Case %d:\n%s + %s = ",i,a,b);
        int len1,len2,j=0,k=0;
    len1=strlen(a)-1; len2=strlen(b)-1;
    for(j=0;len1>=0||len2>=0;j++,len1--,len2--)
	{
    
    
        if(len1>=0&&len2>=0) 
			c[j]=a[len1]+b[len2]-'0'+k;
        if(len1>=0&&len2<0) 
			c[j]=a[len1]+k;
        if(len1<0&&len2>=0) 
			c[j]=b[len2]+k;
        k=0;
        if(c[j]>'9') 
		{
    
    
            c[j]=c[j]-10;
            k=1;
        }
    }
    if(k) 
	printf("1");
    while(j--)
	{
    
    
        printf("%c",c[j]);
    }
        if(i<n) 
		printf("\n\n");
        else 
		printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_46703995/article/details/113094828
今日推荐