HDU-A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 470259    Accepted Submission(s): 90920


 

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2 1 2 112233445566778899 998877665544332211

Sample Output

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

Author

Ignatius.L

注意前导0,如0001,2 输出3,最后一次只换行一次。垃圾代码附上,有时间改的简单点。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
int A[1005]={0},B[1005]={0};
void bigInteger_add(char a[] ,char b[])
{
    memset(A,0,sizeof(A));
    memset(B,0,sizeof(B));
    int lenA=0,lenB=0;
    int lena=strlen(a);
    int lenb=strlen(b);
    for(int i=lena-1;i>=0;i--)
    {
        A[lenA++]=a[i]-'0';
    }
    for(int i=lenb-1;i>=0;i--)
    {
        B[lenB++]=b[i]-'0';
    }
    int r=0,i;
    for(i=0;i<lenA||i<lenB;i++)
    {
        int tmp=A[i]+B[i]+r;
        A[i]=tmp%10;
        r=tmp/10;
    }
    if(r!=0)
        A[i]=r;
}

int main()
{
    int t,num=1;
    char a[1005],b[1005];
    scanf("%d",&t);
    while(t--)
    {
        int flag=0;
        scanf("%s %s",&a,&b);
        bigInteger_add(a,b);
        printf("Case %d:\n%s + %s = ",num++,a,b);
        for(int i=1001;i>=0;i--)
        {
            if(A[i]==0 && flag==0 && i!=0)
                continue;
            else
            {
                flag=1;
                printf("%d",A[i]);
            }
        }
        printf("\n");
        if(t>0)
        {
            printf("\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40099908/article/details/88960076
今日推荐