hdu 1002 A + B Problem II(java)

点击打开链接

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 413635    Accepted Submission(s): 80168


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
 
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

刷ACM的题,大数用C语言写,只能用数组模拟,很麻烦,现在大二了,学习了java,今天做的第一个大数加法题,绝对比C语言要简单的多了。

import java.math.*;
import java.util.*;
import java.*;
public class Main{
    public static void main(String[] args){
        Scanner scanner = new Scanner(System.in);
        int n;
        n = scanner.nextInt();
        for (int i=1;i<=n;i++){
            System.out.println("Case " + i + ":");  
            BigInteger a,b,c;
            a = scanner.nextBigInteger();
            b = scanner.nextBigInteger();
            c = a.add(b);
            System.out.println(a.toString() + " + " + b.toString() + " = " + c.toString());
            if(i!=n){
                System.out.println();
            }
        }
    }
}


猜你喜欢

转载自blog.csdn.net/zhang__liuchen/article/details/80178150
今日推荐