UVA11538 Chess Queen【组合】

You probably know how the game of chess is played and how chess queen operates. Two chess queens are in attacking position when they are on same row, column or diagonal of a chess board. Suppose two such chess queens (one black and the other white) are placed on (2 × 2) chess board. They can be in attacking positions in 12 ways, these are shown in the picture below:
在这里插入图片描述
Figure: in a (2 × 2) chessboard 2 queens can be in attacking position in 12 ways
    Given an (N × M) board you will have to decide in how many ways 2 queens can be in attacking position in that.
Input
Input file can contain up to 5000 lines of inputs. Each line contains two non-negative integers which denote the value of M and N (0 < M, N ≤ 106 ) respectively.
    Input is terminated by a line containing two zeroes. These two zeroes need not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes in how many ways two queens can be in attacking position in an (M × N) board, where the values of M and N came from the input. All output values will fit in 64-bit signed integer.
Sample Input
2 2
100 223
2300 1000
0 0
Sample Output
12
10907100
11514134000

问题链接UVA11538 Chess Queen
问题简述:(略)
问题分析
    n*m的棋盘上,放两个皇后,要求两个皇后可以互相攻击,求有多少种放法。
    组合问题,暂不详细解释。需要考虑横竖斜八个方向都是可以攻击到的。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA11538 Chess Queen */

#include <bits/stdc++.h>

using namespace std;

typedef unsigned long long ULL;

int main()
{
    ULL n, m;
    while(~scanf("%llu%llu", &n, &m) && (n || m)) {
        if(m < n) swap(n, m);
        printf("%llu\n", n * m * (n + m - 2) + 2 * n * (n - 1) * (3 * m - n - 1) / 3);
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10381521.html