A Chess Game

Submit Status

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input

扫描二维码关注公众号,回复: 2703457 查看本文章
 

4 2 1 2 0 1 3 0 1 0 2 0 2 0 4 1 1 1 2 0 0 2 0 1 2 1 1 3 0 1 3 0

Sample Output

 

WIN WIN WIN LOSE WIN

题目大意:给定一个拓扑图,给定棋子位置,两人移动棋子,棋子无处可移为输。问先手是否必赢。 

#include<stdio.h>
#include<vector>
#include<string.h>
using namespace std;
int n;
vector<int>G[1005];
int sg[1005];

int get_sg(int x)
{
	if(sg[x]!=-1)
	return sg[x];
	else
	{
		int Hash[1005];//千万不要把数组开到外面,每次递归调用时都是一个新的hash
		memset(Hash,0,sizeof(Hash));
		for(int i=0;i<G[x].size();i++)
		{
			Hash[get_sg(G[x][i])]=1;
		}
		int j=0;
		for(;j<n;j++)
		{
			if(Hash[j]!=1)
			break;
		}
		sg[x]=j;
		return j;
	}

}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++)
		{
			G[i].clear();
		}
		memset(sg,-1,sizeof(sg));
		for(int i=0;i<n;i++)
		{
			int k;
			scanf("%d",&k);
			if(k==0)
			{
				sg[i]=0;
			}
			else{
				for(int j=0;j<k;j++)
				{
					int x;
					scanf("%d",&x);
					G[i].push_back(x);
				}
			}
		}
		int m;
		while(scanf("%d",&m)!=EOF&&m!=0)
		{
			int sum=0;
			for(int i=1;i<=m;i++)
			{
				int q;
				scanf("%d",&q);
				sum=sum^get_sg(q);
			}
			if(sum==0)
			printf("LOSE\n");
			else
			printf("WIN\n");
		}
	}
}

猜你喜欢

转载自blog.csdn.net/s_h_w_s_n_g/article/details/81356120