杭电ACM-1021 Fibonacci Again

                                         Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 75703    Accepted Submission(s): 34365

 

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0

1

2

3

4

5

 

Sample Output

no

no

yes

no

no

no

斐波那契数列扩展,还是一个水题,题不难,关键在于10^6会溢出,long long 也过不了。

题目要求判断F [ i ]  %  3 是否为 0,数列已给出 

F(0) = 7

F(1) = 11

F(n) = F(n-1) + F(n-2)   (n>=2)

既然数字太多过不了,那么我们考虑找规律,这里有一个规律是:

两个数的余数之和的余数等于两个数和的余数

即:( f [ i-1 ]%3+f [ i-2 ]%3 )%3 = f [ i ] %3

AC代码奉上:

//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
long long int f[1000001];
void fun()    
{
	int i;
	f[0] = 7;f[1] = 11;
	f[0] % = 3;f[1] % = 3;
	for(i = 2;i <= 1000000;i++)
	{
		f[i] = f[i-1] + f[i-2];
		f[i] % = 3;
	}
}
int main()
{
	int n;
	int a,b;
	fun();
	while(cin>>n)
	{
		if(f[n] == 0)
		{
			cout<<"yes"<<endl;
		}
		else
		cout<<"no"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36791466/article/details/84137966