hau1021 Fibonacci Again(递归)

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 72329    Accepted Submission(s): 33039


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 
Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 
Sample Input
0
1
2
3
4
5
 
Sample Output
no
no
yes
no
no
no
 
//(a+b)%c=(a%c+b%c)%c;
#include<iostream>
#include<math.h>
#include<stdio.h>
using namespace std;
long long a[10000005];
int main()
{
  long long n;
  a[0]=7%3,a[1]=11%3;
  for(int i=2;i<1000005;i++)
    a[i]=(a[i-1]+a[i-2])%3;//和DP很像
  while(cin>>n)
  {
    if(a[n]==0)
      cout<<"yes"<<endl;
    else
      cout<<"no"<<endl;
  }
  return 0;

}

猜你喜欢

转载自www.cnblogs.com/-citywall123/p/9509540.html