HDU 1021Fibonacci Again(数学公式)

Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 71520 Accepted Submission(s): 32722

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n).

Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no
公式:(a+b)%m=(a%m+b%m)%m; a*b%m=a%m*b%m;

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    int f[1000000];
    f[0]=7%3;f[1]=11%3;
    for(int i=2;i<1000000;i++)
        f[i]=(f[i-1]%3+f[i-2]%3)%3;
    while(cin>>n)
    {
        if(f[n]==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/81283935