hdu 1021 Fibonacci Again(找规律)

题目:

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0 1 2 3 4 5

Sample Output

no no yes no no no

解题:

代码:

//
//  main.cpp
//  hdu1021
//
//  Created by zhan_even on 2018/10/22.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    int number;
    while(cin >> number){
        if ((number+2)%4==0 ){
            cout<<"yes"<<endl;
        }
        else
            cout<<"no"<<endl;
        
    }
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41568105/article/details/83717925