hdu1021Fibonacci Again(水题)

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 72187    Accepted Submission(s): 32964


http://acm.hdu.edu.cn/showproblem.php?pid=1021

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

 

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

 

Sample Input

0

1

2

3

4

5

 

Sample Output

no

no

yes

no

no

no

找规律。

代码:

#include<iostream>
#include<cstring>
#include<cmath>
#include<iomanip>
#include<algorithm>
#include<cstdio>
#define inf 0x3f3f3f3f
using namespace std;

int main()
{
    int n;
    while(cin>>n)
    {
        if(n==0||n==1)
            cout<<"no"<<endl;
        else
        {
            if((n-2)%4==0)
                cout<<"yes"<<endl;
            else
                cout<<"no"<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sunny_hun/article/details/81666993