(hdu step 3.2.3)Super Jumping! Jumping! Jumping!(DP:求最长上升子序列的最大和)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/caihongshijie6/article/details/43672839

在写题解之前给自己打一下广告哈~委屈。。抱歉了,希望大家多多支持我在CSDN的视频课程,地址如下:

http://edu.csdn.net/course/detail/209


题目:

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 896 Accepted Submission(s): 518
 
Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the maximum according to rules, and one line one case.
 
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
 
Sample Output
4
10
3
 
Author
lcy

题目大意:

                求最长上升子序列的最大和。


题目分析:

                简单DP。求最长上升子序列的最大和。第一层循环用于遍历每一个数,用索引i表示。然后第二层循环用于从头遍历到当前这个数i的前一个数,用索引j表示。如果data[i] > data[j],则说明以索引j结尾的最长上升子序列加上索引i以后依然能构成一个最长上升子序列,但这是依然需要继续向后遍历,因为这是求最长上升子序列的最大和(同一长度的最长上升子序列不唯一)。如果到索引j所形成的最长上升子序列的和大于目前为止的最长上升子序列的和temp,那么就更新temp的值。然后最后通过temp+data[i]便得到了到索引i所能形成的最长上升子序列的最大和。接下来就是更新一下到目前位置所能得到的全局的最长上升子序列的最大和。(上面所说的那个temp只是局部的最长上升子序列)。


至于相求最长上升子序列的长度,可以参考:

http://blog.csdn.net/hjd_love_zzt/article/details/26979313


代码如下:

/*
 * c1.cpp
 *
 *  Created on: 2015年2月9日
 *      Author: Administrator
 */


#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 1005;
int sum[maxn];
int data[maxn];

int n;

int LIS_SUM(){
	int i;
	int j;

	int maxSum = -9999;
	memset(sum,0,sizeof(sum));

	for(i = 1 ; i <= n ; ++i){
		int temp = 0;
		for(j = 1 ; j < i ; ++j){
			if(data[j] < data[i]){
				if(temp < sum[j]){
					temp = sum[j];
				}
			}
		}

		sum[i] = data[i] + temp;

		if(maxSum < sum[i]){
			maxSum = sum[i];
		}
	}

	return maxSum;
}



int main(){
	while(scanf("%d",&n)!=EOF,n){
		int i;
		for(i = 1 ; i <= n ; ++i){
			scanf("%d",&data[i]);
		}

		printf("%d\n",LIS_SUM());
	}

	return 0;
}








猜你喜欢

转载自blog.csdn.net/caihongshijie6/article/details/43672839