hdu1087 Super Jumping! Jumping! Jumping!

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.
 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2

4 1 2 3 4

4 3 3 2 1

0

Sample Output

4

10

3

【题意】找最大的递增的子序列和;

【思路】;dp[i] 表以i 结尾的递增字段和,还是看代码吧

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn=1009;
int dp[maxn],a[maxn];
int main(){
	int n,ans,amxn;
	while(scanf("%d",&n)&&n){
		for(int i=0;i<n;++i){
			scanf("%d",&a[i]);
			dp[i]=a[i];
		}
		ans=dp[0],amxn=ans;
		for(int i=0;i<n;++i){
			for(int j=0;j<i;++j){
				if(a[i]>a[j]){
					dp[i]=max(dp[i],dp[j]+a[i]);//当递增时比较当前i对应dp[i]值与
				}                               //j循环对应的dp[j]值
				
			}
				ans=max(ans,dp[i]);//没有这句会错,3 3 2 1这样递减的 dp[i]始终==a[i]
		}                           //如果输出dp[n-1]就是1,仔细体会
		printf("%d\n",ans);
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_42382758/article/details/82453630