hdu 1087 Super Jumping! Jumping! Jumping!(dp)

                      Super Jumping! Jumping! Jumping!

                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                             Total Submission(s): 46481    Accepted Submission(s): 21537


Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
 
  
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
 
  
4 10 3
 

Author
lcy
 
//题意:给你一个N,然后输入N个数,求从第一个数开始,按顺序选出一组数,在保证绝对递增的情况下,问取出的这组数的最大值是多少?
//理解:dp中得最长递增子序列的变形,现在不是求最长,是求最大(最长不一定最大!),这就很明了。




#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<vector>
#include<cmath>
using namespace std;

typedef long long LL;
const int maxn = 1010;
LL ans = 0;  //输出的结果;
LL dp[maxn];  //dp[i]表示第i个必须使用后产生的最大值;
int a[maxn];

int main(){
    int n, m, r;
    while(~scanf("%d", &m) && m){
        ans = 0;
        for(int i = 0; i < m; i++){
            scanf("%d", &a[i]);
        }
        dp[0] = a[0];  //初始化;
        for(int i = 1; i < m; i++){
            dp[i] = a[i];
            for(int j = 0; j < i; j++){ //这个for循环是用来更新dp[i]的
                if(a[j] < a[i]){  //如果当前的第j个可以放在i前面,则看看能不能更新dp[i];
                    dp[i] = max(dp[i], dp[j]+a[i]);
                }
            }
            ans = max(dp[i], ans); //对于已确定的dp[i],我们找出它的最大值;
        }
        cout << ans << endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/guihaiyuan123/article/details/80098418